How to integrate SAP with Sapho version 4.2 or greater